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1 Introduction
1.1 Maple Flow
Maple Flow is a new calculation tool from Maplesoft. Maple Flow offers a freeform user interface combined with a
comprehensive math engine. Use Maple Flow for engineering, scientific, and technical calculations and documentation.

Maple Flow gives you

• A spatially aware mathematical canvas that replicates the design metaphor of a physical whiteboard

• Automatic recalculation to ensure that results are always up to date

• A broad, rich mathematical language with many functions

• Visually impactful, fully programmatic plots

• A coding region with full access to the Maple programming language

Note for non-Windows users: The keystrokes given in this document are for Windows. If you are using a different
platform, see the keyboard shortcuts for your platform in Keyboard Shortcuts (page 80).

1.2 What Does This Manual Aim to Do?
This manual describes

• The Maple Flow interface

• Differences with the Maple user interface and programming language that an existing Maple user may experience.

This manual should be read in unison with the in-product tutorials and exercises; these are available from the Tutorial
link on the Maple Flow Start page. If you've closed the Start page, you can access it again:

• On the Document tab of the ribbon, in the View group, click Start Page ( ).
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Figure 1.1: Overview of in-product tutorials

This manual does not describe the math functionality of the Maple Flow in detail, but makes references to specific
functions in context of a broader discussion. The detailed documentation for the math functionality resides in the Maple
online help: http://www.maplesoft.com/support/help.

1.3 What Is the Relationship between Maple and Maple Flow?
First, some definitions:

• Maple refers to the (i) Maple programming language and (ii) Maple interface.

• Maple Flow refers to the new product whose manual you are reading.

Maple Flow

• Uses the powerful Maple math engine

• Borrows a few elements from the Maple interface

Maple Flow's "language" is the commands (and their syntax), data structures and programming language. These are
based on the Maple programming language; you can use any of the math functions in Maple in your Maple Flow analyses.

2 • Introduction
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1.4 If You Are a Maple User
If you already use Maple, you'll appreciate the unique twist that Maple Flow offers with its spatial evaluation model
and automatic calculation updates. You will also get a head start because you'll be familiar with Maple's programming
language, functions, and features.

Maple Flow differs from the Maple interface and programming language in a number of ways. Several important dif-
ferences are listed in Table 1.1.

Table 1.1: How Maple Flow differs from Maple

MapleMaple Flow
You can enter commands at execution prompts, which are
largely aligned to the left (except when inserted into

You enter math and text at any point, simply by clicking with
your mouse, and typing.

multicolumn tables), and linearly progress down the
worksheet.This is in much the same way that you can write math at any

point on a whiteboard.
The evaluation model is forward in time. You can use
assignments above or below where they are made, at any time

The evaluation model is forward in space. Any assignments
are only valid at any point to the right or below where they
are made. after the assignment is made.

Most users progress linearly down a worksheet, but the
apparently linear form of a worksheet is not always reflected
in the displayed results.
Multiplication can be implicit (i.e. entered with a space) or
explicit.

Multiplication needs to be explicitly stated.

Results are kept symbolic except when requested to be numeric
(for example, with the evalf command).

More numeric evaluation by default (for example 5/10
evaluates to 0.5)

Units are only reconciled if explicitly requested by the user
(for example, by loading a Units package).

Units are automatically combined. That is, N/m2 is
automatically reconciled to Pa.

Individual commands, groups of commands, or entire
worksheets are only updated if requested by the user. This
means results may not reflect the current value of definitions.

What you see in the Maple Flow canvas is always up to date
and reflects the current state of all assignments. Any changes
or additions to the canvas automatically cascade down the
canvas.

Automatic recalculation means the currently visible portion
of the canvas updates as you work, and as you scroll through
the document all the calculations are updated.

Matrix, vector, and array indices can be entered with square
brackets or typeset subscripts (in 2-D input).

Matrix, vector, and array indices are only entered with square
brackets.

Equations and programs can be entered in typeset mathematics
notation (often called "2-D math") or Maple notation ("1-D
math").

Math is entered into the canvas in mathematical notation, but
programmatic content is entered in Maple notation.

Maple worksheets cannot be loaded into the Maple Flow, or vice versa.

1.5 Maple Flow Help System
The in-product help system provides information on key commands. Each help page gives details on the usage of a
command, including the calling sequence, parameters, options, and examples.

To open the help system:

• On the Help tab of the ribbon, click Maple Flow Help ( ).

Search: Search for a command name, keyword, or phrase.
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Browse: Browse the table of contents to view a structured list of help topics.

To get help on a specific word:

1. In a worksheet, place the cursor in a word for which you want to obtain help.

2. On the Help tab of the ribbon, click Help on Context ( ), or press the shortcut key F2.

View Help Page as Worksheet: You can open any help page as a worksheet to interact with the page and modify the
examples.

• With the help page displayed in the right pane of the help system, from the View menu, select Open Page as
Worksheet.

• Alternately, click Open current page as worksheet ( ) in the help system toolbar.

Additional Documentation

Since Maple Flow uses the Maple programming language, you have the ability to use the vast math functionality that
is part of the Maple programming language. When browsing the help system, some hyperlinks take you to additional
detailed documentation for the math functionality that reside on the Maplesoft website, in the Maple online help:
http://www.maplesoft.com/support/help. Note that these pages are formatted as Maple pages, not Maple Flow pages,
so the examples will look a little different.

1.6 Interface
The different parts of the Maple Flow interface, as seen in Figure 1.2, are:

• Canvas — the workspace

• Quick access toolbar — The toolbar at the top of the Maple Flow window provides quick access to commonly used
commands.

• Ribbon interface — The ribbon organizes tools in tabs for ease of access.

• Palettes — In the left pane, these provide an easy way to enter a math expression, matrix, Greek letter, or units. A
second tab in this pane contains the AI Formula Assistant.

• Context panel — Some options relevant to the current selection appear here, such as numeric formatting and units
formatting.

• Status bar — Displays system information

4 • Introduction
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Figure 1.2: The Maple Flow interface

Using the Ribbon Interface

Click a tab (such as Home or Math) to view it. The layout of the contents in the ribbon changes to fit the size of your
Maple window. If necessary, click an arrow ( ) to see the buttons in a group.

You can collapse the ribbon usingMinimize/Maximize ribbon ( ) on the quick access toolbar, or by double-clicking
on the active tab. When the ribbon is minimized, clicking Minimize/Maximize ribbon ( ) expands the ribbon. Al-
ternatively, when the ribbon is minimized, you can access the contents of a tab by clicking the tab. The tab stays expanded
until you click away from it.

Press the Alt key to see small keyboard tips that open tabs and groups and click items in the ribbon. Press the Alt key
again to stop displaying the keyboard tips.

For example, typing Alt shows the keyboard tips. Press M to open the Math tab and then press D to open the Import
Data assistant.

Customizing the Interface

Customize your Maple Flow preferences using the Options Dialog.

To open the Options Dialog:

• From the File menu, click Options ( ).

There are six tabs.

5 • Introduction



Under the Units tab, you can specify the default unit system (SI, FPS, or IPS). For more information, see Setting the
Default Unit System (page 42).

Under the Display tab, you can customize settings related to display of output. For more information, see Numeric
Formatting (page 14), Complex Numbers and Phasors (page 17), and Set Displayed Matrix Size (page 50).

Figure 1.3: Options dialog

Under the Interface tab, you can specify the following:

• Open worksheets in new tab or new window.

• Open hyperlinks in new tab or new window. This refers to hyperlinks to other Maple Flow worksheets.

• Default zoom.

• Open worksheet at startup. You can select the worksheet that Maple Flow displays as the Start page. See the next
section for more information.

• Control the Automatic argument completion feature. For more information, see Argument Completion (page 59).

Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the setting
to the current session an future sessions.

Under the Evaluation tab, you can customize settings related to evaluation. For more information, see Controlling
Evaluation (page 20).

Under the General tab, you customize settings related to saving. You can set the matrix save limit, control auto save
settings, and enable saving of debugging information to a log file. For more information, see Set Matrix Save
Limit (page 51), Restore Backup (page 61), and Logging Debugging Information (page 62). You also can read and
agree to the AI terms of use in the General tab. For more information, see Set Matrix Save Limit (page 51).

Under the Template tab, you can customize settings related to default page layout. For more information, see Page
Setup (page 68).

Working in Maple Flow

By default, Maple Flow opens to the Start page. From this page you can access the tutorials and many sample applications.
If you close this page, you can always return to the start page: on the Document tab of the ribbon, in the View group,
click Start Page ( ).
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You can customize what worksheet Maple Flow displays as the start page, or have it simply display a new, blank
worksheet on start up.

• From the File menu, click Options ( ).

• Under the Interface tab, select the desired start page: Default start page, Specified worksheet, or New, blank.

• If you select Specified worksheet, browse to the desired document. (Tip: You may want to make your custom start
page noneditable, as described in Controlling the Editability of a Document (page 29).

• Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session an future sessions.

By default Maple Flow documents open in a new tab. (That setting can be changed in the Options > Interface tab as
well.) You can always move a Maple Flow document from a tab to a new window.

To move a Maple Flow document to a new window:

• Grab the document tab, and drag it away from the menu bar. The document opens in a new Maple Flow window.

You can also reorder the tabs by dragging them in the menu bar.
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2 Canvas
2.1 Grid
When you drag math and text containers, the positions of containers are snapped to a grid. By default, the grid is not
displayed.

To display the grid:

• On the Document tab of the ribbon, in the View group, click Grid ( ).

2.2 Grid Cursor
The grid cursor is illustrated in Figure 2.1 and by default appears in the top left corner of every new canvas.

Figure 2.1: Grid cursor

The grid cursor can be moved by pointing and clicking with the mouse, or with the arrow keys.

Math and text containers are created at the location of the grid cursor.

2.3 Math and Text Containers
On the canvas, you can create math boxes or text boxes. Each box can be moved; the position of a math container de-
termines the order in which it is evaluated (as illustrated in Figure 3.11).

A container can be in one of three states, as described in Table 2.1.

Table 2.1: Container states

TextMath
Stationary with no focus. A math container
in this mode is still "live", and Maple Flow
will update its result if an upstream
parameter changes.

Numeric:Editing

• Only one container can be in editing
mode at any one time.

• A math container has a solid dark green
border if numeric, or a dashed light green

Symbolic:border if symbolic (see Numeric and
Symbolic Evaluation Modes (page 13)).

• A text container has a blue border.

• You will see a flashing cursor, whose
position can be changed with the arrow
keys or mouse.

Move

• Math and text containers that are selected
have a light blue border. Such a container
is in move mode.

• One or several containers can be in move
mode.
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TextMath
• Move the containers with the mouse.

• When instead you select using the
keyboard andCtrl key, the container has
a royal blue border.

• Move the container with Ctrl + arrow
keys.

2.4 Moving Containers
Single Container

With the mouse

To move a container with the mouse:

1. Move the mouse pointer over a container.

2. Move the container to another position by click and dragging.

3. Release the mouse button when the container is in the desired position.

With the keyboard arrows

To move a container with the keyboard:

1. Move the grid cursor into a container so that the container is in editing mode.

2. Do one of the following:

• Press Ctrl and use the arrow keys to move the container one grid space at a time.

• Press Ctrl + Shift and use the arrow keys to move the container a single pixel at a time.

Note that when you press Ctrl, the container border changes to royal blue to indicate Ctrl has been pressed.

Group of Containers

To move multiple containers:

1. Click in a blank part of the canvas.

2. Drag a selection box around a group of containers.

3. Release the mouse button.
Alternatively, you can press and hold Ctrl while you select the containers.

4. Move the mouse pointer over one of the selected containers.

5. Drag the containers to another location.

To align containers:

1. Click in a blank part of the canvas.

2. Drag a selection box around a group of containers.

3. Release the mouse button.

4. On the Document tab of the ribbon, click Align Left ( ).
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Bringing Containers from Back to Front, and Vice Versa

You can potentially have two containers at the same grid position.You can bring the lower container forward, or send
the top container back, by using Move to Front and Move to Back buttons.

On the Home tab of the ribbon, in the Display Order group, click Move to Front or Move to Back.

Figure 2.2: Flip to Front and Flip to Back buttons

2.5 Editing an Existing Container
To enter editing mode on an existing container, do one of the following:

• With the mouse, click the container.

• With the arrow keys, move the grid cursor onto the container.

2.6 Deleting a Container
To remove a container, do one of the following:

• With the mouse, select the container (or containers) and on the Home tab of the ribbon, click Cut ( ).

• Move the grid cursor into a container so that the container is in editing mode. Then press Ctrl + Delete to delete the
in-focus container.

• Triple-click the container to select the entire container, then press Delete.

2.7 Inserting or Removing White Space
You can insert or remove space in the canvas (i.e. grid rows) by using the Enter, Backspace, and Delete keys.

Adding Blank Rows

To add blank rows, place the grid cursor on a blank part of the canvas and press Enter. This shifts all content on and
below the same row as the grid cursor down.

Deleting Blank Rows

To delete blank rows, click on a blank row of the canvas and do one of the following:

• Press Backspace to remove that blank row and shift the grid cursor and all content below the grid cursor up.

• Press Delete to remove that blank row, and shift all content below that row up.

• On the Document tab of the ribbon, in the Empty Rows group, click one of Delete Rows Above, Delete Rows
Below, or Delete Rows Above and Below.
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3 Entering Math
3.1 Creating a Math Container
A math container is a box in which you enter math that is to be evaluated.

To create a math container:

1. Click on a blank part of the canvas.

2. Begin typing your math. As soon as you enter the first character, a math container is created automatically.

3.2 Deleting a Math Container
To delete a math container, do one of the following:

• Drag-select the math container and press Delete.

• In editing mode, press Ctrl + Delete to delete the in-focus container.

• Triple-click the container to select the entire container, and then press Delete.

3.3 Copying and Pasting Math
When you are copying from outside of Maple Flow, for example from a text document, by default the content is pasted
into your Maple Flow worksheet as text. If you are copying a math expression, there is an easy way to ensure it pastes
as math.

To copy and paste as math:

• Select and copy the math.

• To paste as math, click on a location in the worksheet, and then on theHome tab of the ribbon, click the arrow below

Paste ( ) and then click Paste as Math. Alternatively, right-click on a location in the worksheet and from the
context-sensitive menu select Paste as Math.
A new math container is created, and the selected math is copied into it.

3.4 Evaluating Math and Displaying Output
Anytime you leave a container by pressing Enter, or navigating away using Tab or the arrow keys, evaluation occurs.

All math is evaluated in the canvas, using a left-to-right, top-to-bottom order (see Evaluation Order (page 20)). When
you need to display results, evaluate and display output.

To evaluate math and display results:

• Enter the expression, then press =. The evaluation occurs and the result displays. The focus remains in the math
container.

If desired, press Enter or the arrow keys to leave the math container.

Typically all visible calculations that are dependent on a math container are updated when the focus leaves a math
container.

You can change the behavior of = in a math container, if desired. See Controlling Evaluation (page 20).

11



3.5 Creating Definitions and Expressing Equality
Definitions

You can assign a numerical value or an expression to a name by using := (a colon, followed by an equal sign).

For example, entering in a math container assigns the value 4 to the name a.

You can then use this definition later.

Expressing Equality

As discussed in Evaluating Math and Displaying Output (page 11), by default the equal sign is used to evaluate and
display results. When you are entering an expression into a math container that involves an equation, use Ctrl + = to
enter the equal sign. This allows entry of the = symbol without immediate evaluation of the math container.

Example 1.

Solve this equation for x:

A one-line solution is:

Notice there are two equal signs in this math container. The first one is part of the equation. The second one means
evaluate and display results, and at the end you see the two solutions: 3.828 and -1.828.

An alternative approach is to first define the equation, then solve for the result.

In both cases, use the following steps:

• To enter the equal sign between the left-hand side and right-hand side of the equation, use Ctrl + =.

• To enter the equal sign that means evaluate and show results, use =.

Example 2.

When the calling sequence for a command includes an option of the form name=value.

For example, on the CurveFitting:-LeastSquares help page, there is an example using the option weight:

In this example, use Ctrl + = to put the equal sign in weight=[1, 1, 1, 10].

When Visual Indicators on the Document tab of the ribbon is toggled on, the = for equality is displayed in bold. For
more uses of the visual indicators setting, see Hiding Commands (page 28).

You can change the behavior of = in a math container, if desired. See Controlling Evaluation (page 20).
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3.6 Numeric and Symbolic Evaluation Modes
Maple Flow offers two math evaluation modes—numeric and symbolic.

Figure 3.1: Select Numeric or Symbolic Mode

Table 3.1: Difference between numeric and symbolic evaluation modes

Symbolic evaluation modeNumeric evaluation mode

The numeric evaluation mode performs as much numeric evaluation as possible. For example:

• Rational fractions (such as ½) are converted to floating-point numbers

• Pi and exp(1) evaluate to floating-point numbers

Symbolic evaluation mode prevents numeric evaluation (except when requested by the user). For example:

• Rational fractions are only converted to floating-point numbers if request by the user (e.g. with the evalf command)

• Pi evaluates to a symbolic name

In both modes, unassigned names are evaluated symbolically (i.e. in numeric mode, unassigned names do not give an
error when evaluated).

The current mode of an existing math container is given by clicking inside it, and observing the state of the border, as
illustrated in Table 3.1.

By default, new math containers are numeric. To toggle a math container to symbolic mode:

• On the Math tab of the ribbon, in the Entry Mode group, click Symbolic ( ). The in-focus math container
switches to symbolic mode. Alternatively, use the shortcut key Alt + S.

To toggle a symbolic math container to numeric mode, on the Math tab of the ribbon, in the Entry Mode group, click

Numeric ( ).

To make symbolic evaluation mode "sticky," click the arrow below Symbolic and then click Lock Symbolic ( ). The
Symbolic icon in the Math tab changes to indicate symbolic mode is locked. Now all future math containers will be
symbolic by default (until symbolic mode is toggled off, by clicking Lock Symbolic again).
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3.7 Numeric Formatting
By default, Maple Flow displays numeric results with three decimal places. To customize the numeric formatting:

1. Place the editing cursor on a numeric result.

2. Use the Number Format options in the Context Panel.

Figure 3.2: Numeric formatting

Note that the number format options in the Context Panel only apply to a single math container.

To select a number format and apply it broadly, you can use the Options Dialog to set your desired number format and
apply it either to the current session or globally.

1. From the File menu, click Options ( ).

2. Under the Display tab, select the desired number format.

3. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.

Figure 3.3: Setting default numeric formatting

Maple Flow supports the following standard number formats:

• Fixed

• Currency

• Scientific
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• Engineering

• Percent

You can also create a Custom format.

To apply a custom format to a single math container:

1. Place the cursor in the numeric result to be formatted.

2. In the Context Panel, under Number Format, select Custom. In the custom string field you can enter a string that
is specific to your formatting needs.

Examples include the following:

• #.### formats to 3.12

• 00.000 formats to 03.120

• #,#.# formats to 2,100,320.5

• $0.00 formats to $123.50

• ??0.00;[Red](??0.00) formats to blue for a positive number, and red for a negative number

• [<10]Low;[>=100]High;Medium formats to "Low" for numbers less than 10,"High" for numbers less than or
equal to 100, and "Medium" otherwise

To apply a custom format to all numeric results in the current session or globally:

1. From the File menu, click Options ( ).

2. Under the Display tab, for Number format select Custom and enter your specification in the custom string field.

3. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.

To remove a number format, return to the Number Format dialog and select None.

3.8 Basic Arithmetic
Equations are entered in typeset math notation, using standard keys such as /, *, + and -.

Note that multiplication must always be explicitly stated. For example, you must enter 3*x, not 3x. Failure to do this
may lead to errors, as shown in the following figure. (To fix this, enter a multiplication symbol between x and y, and
another between the fraction and d.)

You can also use the Expression palette or Command Completion feature to enter typeset math, as illustrated in Table
3.2.
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Table 3.2: Using the Command Completion feature and Expression Palette to insert a square root

(b) Expression palette(a) Command completion

For more information on command completion, see Command Completion (page 58).

When you select a template, you can then replace the placeholders in the template, using Tab to move between place-
holders.

Tips on piecewise functions:You can enter a piecewise function using the Expression palette or command completion.
To add an additional line to the piecewise function, place your cursor in the piecewise function and right-click. From
the context menu, select either Insert RowAbove or Insert RowBelow. Similarly, you can remove a row usingDelete
Row in the same context menu. Triple-click to select the entire piecewise function.

3.9 Units
Entering Units

You can enter units in several different ways.

Units Palette

You can enter units using the Units palette located in the Palettes pane on the left side of the Canvas. Click the desired
unit (using the Dimensionality drop-down list to switch to different groups of units), or insert the unit placeholder (as
illustrated in Figure 3.4) and overwrite the placeholder.

You may want to place a space between the number and the unit.

Figure 3.4: Inserting a Unit with the Units Palette
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Unit function

You can use the Unit() function to assign a unit.

Figure 3.5: Using the Unit() function to assign a unit

Keyboard shortcut

Press Ctrl + Shift + U to enter a unit placeholder. Then, replace the placeholder with the desired units.

Figure 3.6: Using keyboard shortcuts to insert a unit placeholder

Editing Existing Units

Move the cursor onto the unit. When the unit has focus, it is highlighted by a light blue box. You can now change the
unit.

Deleting all the characters in a unit placeholder will leave an empty placeholder one character in size. Deleting this
empty placeholder will remove the unit placeholder entirely.

When the results of your calculations contains units, you can use the units formatting options in the Context Panel to
rescale the units to units you'd prefer to see.

Figure 3.7: Convert output units

Further tools for working with units are described in More Controls for Units (page 42).

3.10 Complex Numbers and Phasors
You can work with complex numbers and phasors.

Entering Complex Numbers

Imaginary numbers are entered with a number followed by the suffix i, with no multiplication between the two. For
example, 2+2i.

The unit complex number is created with 1i. You cannot just enter i for the unit complex number.
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To create a symbolic multiplier on an imaginary number, you need to enter x*1i.

Entering Phasors

You can enter a phasor using the Common Symbols palette or command completion.

To enter a phasor using the Common Symbols palette:

1. Enter the value for the magnitude r.

2. From the Common Symbols palette, click the phasor symbol ( ).

3. Enter the value for θ.

To enter a phasor using command completion:

1. Enter the value for the magnitude r.

2. Type angle, press Esc to initiate command completion on the word angle, and select the phasor symbol ( ).

3. Enter the value for θ.

By default, the angle is assumed to be in radians. You can use the unit deg (or degree) if you want the angle to be in
degrees. From the Units palette, click the unit placeholder ( ), and then replace the placeholder with deg. (For more
information on entering units, see Entering Units (page 16).)

Note: To perform arithmetic operations such as multiplication with expressions involving phasors, use parentheses
around the phasors to make the order of operations clear.

Displaying Phasors in Output

By default, outputs involving complex numbers are displayed using a+ bi formatting.

You can display the output in phasor notation using the number format options in the context panel.

To display results using phasor output in a single math container:

1. Place the cursor in the numeric result to be formatted.

2. In the Context Panel, under Number Format, select Phasor. By default, the angle is in radians.

3. To display the angles in degrees, also select Unit on angle, and Degrees to rescale the result.

Figure 3.8: Phasor options in the context panel
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To display all results using phasor output in the current session or globally:

1. From the File menu, click Options ( ).

2. Under the Display tab, under Number format select Phasor.

3. To display the angles with units, also select Unit on angle. The angle will be shown with unit rad (radians).

4. To display the angles with units in degrees, also select Degrees.

5. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.

You can display a phasor output using symbolic evaluation mode using the Symbolic button in the Math tab of the
ribbon, as shown in Table 3.3. (For more information on Numeric/Symbolic results, see Numeric and Symbolic
Evaluation Modes (page 13).)

Table 3.3: Phasors evaluated numerically and symbolically

Symbolic evaluation modeNumeric evaluation mode

3.11 Notes about Calculations
Numerical Evaluation and Accuracy

Any purely numerical operations are evaluated to a floating-point approximation.

Figure 3.9: Numerical operations

The Digits environment variable controls the number of digits that Maple uses when making calculations with software
floating-point numbers.
The default value of Digits is 10. The value of Digits is changed with the assignment operator (e.g. Digits:=15).

Figure 3.10 illustrates the effect of changing digits from its default value of 10 to 15 on the evaluation of . (Note
that numeric formatting on the result of has been set to Fixed with 20 decimal places.)

Figure 3.10: The effect of Digits on numerical accuracy
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Evaluation Order

Maple Flow evaluates calculations from left-to-right, top-to-bottom (much like reading a page from a book). This
means that downstream calculations only "see" assignments on the left or above. This is illustrated in Figure 3.11.

Figure 3.11: Spatial evaluation

You can change the evaluation order by moving math containers around.

Nonexecutable Math

You may want to enter nonexecuting math for documentation purposes. You can do this by entering math into a text
container. For details, see Entering Math in a Text Container (page 23).

Controlling Evaluation

By default, Maple Flow recalculates all visible dependent containers when a math container is created, edited, or moved.

You can also force evaluation when your cursor is in a math container by using Ctrl + Enter.

When the calculations are in progress, the status bar at the bottom of the Maple Flow window displays a status message:
Evaluating... m/n where n is the total number of math containers being evaluated.

To stop the current calculation:

• From the status bar at the bottom of the Maple Flow window, click the Interrupt icon, ( ).

The Options dialog contains settings you can control related to evaluation.

If you want the entire worksheet to be updated when you make an edit, you can change the settings to recalculate all
dependent containers in the entire document, rather than just visible containers.

1. From the File menu, click Options ( ).

2. Click on the Evaluation tab.

3. Under Content to evaluate, select one of the following:

• Evaluate only visible containers (the default)

• Evaluate all dependent containers

4. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.
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Figure 3.12: Setting for controlling evaluation

Under the Options > Evaluation dialog, you can also change the meaning of = in a math container. Under Evaluation
keys, select one of the following:

• = to evaluate math and display results, and Ctrl + = for equality (the default). When typing in a math container
in this mode, at any location you can use the = key to have the math container evaluate and show results. Ctrl + =
is used to type an equal sign without causing immediate evaluation.

• = + Enter at the end of math to evaluate and display results, and = for equality . The equal sign can by typed
without causing an evaluation. To get a math container to display results, enter the expression, then with the cursor
at the right end of the expression, press =, followed by Enter (or move the focus outside of the container).

After you make your selection, click Apply to Session or Apply Globally.

UnderOptions > Evaluation, you can control whether a worksheet is executed when it is opened. Under When loading
a worksheet, select one of the following:

• Don't execute the worksheet (the default)

• Execute the worksheet

If Execute the worksheet is selected, when a file is opened, for consistency between saved results and worksheet
display settings, auto-evaluation on load happens if needed. For instance, this would ensure output units and matrices
are displayed according to the current settings.

If Don't execute the worksheet is selected, no auto-evaluation happens on load.

After you make your selection, click Apply to Session or Apply Globally.

A similar setting controls whether a worksheet is executed when it is saved.

Disabling Evaluation

If you want to author content without any math evaluating in the Maple Flow worksheet, but eventually the math will
be executed, you can temporarily disable evaluation.

21 • Entering Math



To disable evaluation:

• On the Math tab of the ribbon, click Toggle Evaluation. An indicator appears at the top of the canvas indicating
Evaluation Disabled.

Figure 3.13: Worksheet evaluation disabled

To enable evaluation:

• Click the icon again.

To disable evaluation of a single math container, do one of the following:

• Select the container and on the Math tab of the ribbon, in the Evaluation group, select Toggle Component ( ).

• Right-click on the container and from the context menu, select Disable Evaluation.

There is an option to display a visual indicator for math containers that have evaluation disabled. To enable this setting,
on the Document tab of the ribbon, in the View group, click Visual Indicators. When Visual Indicators is selected,
a math container with evaluation disabled is drawn with a red circle at the top left corner.

Figure 3.14: Visual indicator for disabled evaluation

To show the command again, right-click and clear the Disable Evaluation check box from the context menu.
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4 Creating a Polished Document
4.1 Entering Text
To enter text:

1. Click in a blank part of the canvas.

2. Press Space to create an empty text container. This will have a blue border.

3. Type your text.

4. Use the options on the Home tab of the ribbon to format your text.

Figure 4.1: Entering and formatting text

Spellcheck ( ) is available on the Document tab of the ribbon.

Entering Math in a Text Container

You may want to enter nonexecuting math for documentation. You can do this by entering math into a text container.

To enter math in a text container:

1. Anywhere inside a text container, press Ctrl + R to switch into math mode.

2. Enter your math.

3. If required, press Ctrl + T to return to text mode.

4.2 Math and Text Styling
Formatting the Content of Single Containers

To change font, size, and font color, drag-select the content and use the ribbon.

Applying Background Color to a Math or Text Container

Math and text containers can also have a background color. This can be useful, for instance, to highlight a math con-
tainer that contains the assignments for the variables that are used in the later calculations.

To apply a background color,

1. On the Document tab of the ribbon, click Background Color ( ). Alternatively, right-click on a container and
select Background Color.
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Figure 4.2: Apply background color to a container

2. The color selector dialog appears. Select a color.

Figure 4.3: Select background color

To apply a background color to multiple math containers, select the math containers, then click Background Color

( ).

Figure 4.4 shows the result of using a background color on the math containers that define two assignments, and an-
other color on the plot.
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Figure 4.4: A math container with background color

For information on creating plots, see Plots (page 46).

Formatting Text

In text containers, you can control the formatting of text.

On theHome tab of the ribbon, the options in theFont group can be used to apply bold, italic, underline, or strikethrough
to text, to make a subscript or superscript in the text, or to change the text color or highlight text.

Applying and Changing Styles

The style drop-down list contains several formatting styles for text and math. This is found on the Home tab of the
ribbon, in the Paragraph group.

Figure 4.5: The Styles drop-down list

By default:

• Text is given the Text style.

• Math input is given the 2D Math style.

• Math output is given the 2D Output style.
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You can apply other styles with the other entries (such as the Title, Heading 1, and Heading 2 styles for text). You
will need to select the content and then pick the appropriate style. You can select text by clicking in the container and

then using Home > Select All ( ) or drag-select.

Using style sets is a way to have a consistent look across multiple documents.

To change the typeface of the pre-defined styles in the current document, on the Home tab, in the Manage Styles

group, click Styles ( ).

On the Home tab, in the Manage Styles group, click Manage Style Sets ( ) to:

• Export and save the active style set from the current document.

• Load and apply an existing style set to a document.

4.3 Using Sections
You can use sections to organize your document.

To create a section:

1. On the Document tab of the ribbon, in the Insert group, click Section ( ).
If you select some content and then use Insert > Section, the selection will be enclosed in the section.

2. Enter a title for the section. You can modify the font/style for the title.

To change the size of the section, you can drag the bottom boundary line. If you drag the section boundary past addi-
tional content, the section now encloses that content.

To collapse a section:

• Click the collapse button ( ).

To expand a section:

• Click the expand button ( ).

Figure 4.6 shows an example of a Maple Flow worksheet with sections. The first section is collapsed and the second
section is expanded.

Figure 4.6: Sections in a worksheet

Evaluation order still applies as it normally does, and content in a section is evaluated even if a section is collapsed.
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Controlling the Display of Sections

You can edit a section title by clicking in the text box for the title, or by clicking on the top boundary line.

Tip: If a section does not have a title, click on the top boundary line. This opens the title text box for editing.

You can control the display of sections using Document > Section Style ( ). From this dialog, you can

• Control whether to display the top and bottom boundary lines.

• Control whether boundaries are displayed on only the left-most page.

• Specify margins.

• Specify boundary line thickness.

• Specify boundary line color.

• Specify boundary opacity.

• Control whether to display the expand button.

Note that if the section style is set up so the expand/collapse button is not displayed, you can expand or collapse a
section by doing one of the following:

• Click the left most part of the top section boundary line

• Double-click anywhere along the top section boundary line.

For information on controlling the display of sections when printing or exporting to PDF, see Printing a Worksheet
with Sections (page 69).

Removing a Section

To remove a section:

• On the Home tab of the ribbon, click Remove Section ( ). The content remains in the canvas, and the section
boundaries are removed.

4.4 Controlling Display of Math
When creating a document, you can control some aspects of the display of the content of math containers. For instance,
you can control numeric formatting, as described inNumeric Formatting (page 14). This section describes some further
customizations.

Aligning Results under the Definition Operator

Typically, math output appears inline with the input. In the case that you are making a definition and displaying the
output, you can choose instead to align the result on a new line, under the definition operator. This can help with
readability. Figure 4.7 shows an example in which the output of the stress definition is displayed below.

Figure 4.7: Align Output Below :=
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To align the result on the next line, below the := operator:

1. Enter the definition and press = to evaluate and display results.

2. With focus in the math container, on the Document tab of the ribbon, click Align on Newline ( ). The result is
now on a newline, aligned with the definition operator.

Hiding Commands

When creating a document, you can hide the input expression and just show the resulting output. The commands for
this feature are found on the Math tab of the ribbon, in the Hide Commands group. They can also be accessed by
right-clicking on a math container and using the context menu.

To hide the input expression:

1. Select the math container.

2. On the Math tab, in the Hide Commands group click Hide commands.
In the case of an assignment, you can click either Hide commands or Hide commands and name.

Figure 4.8: Hide commands

There is an option to display a visual indicator for math containers that have hidden commands. To enable this setting,
on the Document tab, in the View group, click Visual Indicators. When Visual Indicators is toggled on, a math con-
tainer with hidden commands is drawn with a gray circle at the top left corner.

Figure 4.9: Marker indicates hidden command

To show the command again:

• Select the math container, and then on the Math tab, in the Hide Commands group click Show commands.
Similarly, you can click Show name if the name has been hidden.

You can also perform the hide commands action on multiple math containers.

3. Drag a selection box around a group of math containers.

4. Release the mouse button.

5. On the Math tab, in the Hide Commands group click Hide commands or Hide commands and name.
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4.5 Controlling the Editability of a Document
You can protect the content in a document from changes by marking either the entire document as noneditable.

When a document is marked as noneditable, existing content in the document cannot be modified. For example, the
Start page that appears when you first open Maple Flow is a noneditable document.

To prevent changes to a document, ensure the document is noneditable:

• In the status bar at the bottom of the Maple Flow window, clear the Editable check box.

When a document is noneditable, users can view the document, open and close sections, and click links, but cannot
change content.

To change any part of a document, ensure the document is editable:

• In the status bar at the bottom of the Maple Flow window, select the Editable check box( ).

4.6 Creating Hyperlinks
You can add a hyperlink to a worksheet that links to another Maple Flow worksheet, a webpage, and more.

To insert a hyperlink:

1. With the cursor in a text container, on the Document tab of the ribbon, in the Insert group, click Hyperlink ( ).
The Hyperlink Properties dialog opens..

2. For the Link Text field, enter the text to be shown.

3. Select the link type.

4. For the Target field, enter the destination. Note that you have to save your document if you want to use a relative
path.

5. Optionally, you can add a hyperlink tooltip.

You can also create a hyperlink by selecting some text and, on the Home tab of the ribbon, clicking Convert To >
Hyperlink ( ).

To edit the hyperlink properties, right-click on the hyperlink and select Hyperlink Properties.

You can create a hyperlink to a Maple Flow help page. For example, setting Type to Help Topic and Target to solve
creates a link to the solve help page.

Figure 4.10: Help Topic Hyperlink

Using Bookmarks

Bookmarks allow you to mark a specific position in a worksheet. After you have created a bookmark, you can create
a hyperlink to that bookmark.
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You can create a bookmark for a section title, text container, math container, or image.

To create a bookmark:

1. Place the cursor at the location where you want the bookmark.

2. On the Document tab of the ribbon, in the Insert group, click Bookmark ( ). The Bookmarks dialog opens.

3. Click New. The Create Bookmark dialog opens.

4. Enter a bookmark name and click Create. The new bookmark appears in the Bookmark dialog list. Click OK to
accept this bookmark.

You can link to a bookmark using a hyperlink. You can link to a bookmark in the same worksheet or in another
worksheet.

To create a link to a bookmark in the same worksheet:

1. With the cursor in a text container, on the Document tab of the ribbon, in the Insert group, click Hyperlink. The
Hyperlink Properties dialog opens.

2. For the Link Text field, enter the text to be shown.

3. Select Worksheet from the Type drop-down menu.

4. Leave the Target field blank to link to a bookmark in the current document.

5. From the Bookmark drop-down menu, select the desired bookmark. All bookmarks in the current worksheet are
available.

Figure 4.11: Link To Bookmark

6. Optionally, you can add a hyperlink tooltip.

7. Click OK. The hyperlink is created.

You can also create a hyperlink to a bookmark by selecting some text and, on the Home tab of the ribbon, clicking
Convert To > Hyperlink ( ).
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To create a link to a bookmark in another worksheet, the steps are analogous, but for the Target field, enter or browse
to the desired Maple Flow worksheet.

Additional Notes:

• To navigate to a bookmark in the current worksheet, on the Home tab, click Go To Bookmark ( ).

• You can rename or delete an existing bookmark from Document > Insert > Bookmark ( ).

• There is an option to display a visual indicator for bookmarks. To enable this setting, clickView >Visual Indicators.
When Visual Indicators is selected, a container or other location in the document that has a bookmark is drawn with
a dark gray square at the top left corner.

Using Shortcuts

In addition to hyperlinks, your worksheet can contain shortcut components, which are clickable image links. The default
look of a shortcut is shown in Figure 4.12, but you can change the image used. The Application Gallery in Maple Flow
uses shortcuts.

Figure 4.12: Shortcut

To insert a shortcut:

1. Click on the canvas.

2. From the Components palette, click the Shortcut icon ( ). A shortcut component is inserted at the cursor.

3. To edit the shortcut properties, select the shortcut component, and in the Context Panel the shortcut properties are
available.
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Figure 4.13: Shortcut Properties

4. Specify a caption, which appears below the image. Optionally, add a tooltip.
Note: The Name field is used by Maple Flow to identify the component. The caption is what is visible.

5. Specify a link target. You can link to a Maple Flow worksheet or URL. You can also use the shortcut component
to open a blank Maple Flow worksheet, execute one line of Maple code, or open a help topic.

Figure 4.14: Using a Shortcut to execute code

6. If desired, change the image.

4.7 Including a Table of Contents
When creating a document, you can include a table of contents.

To insert a table of contents:

1. Click a blank part of the canvas.

2. On theDocument tab of the ribbon, in the Insert group, clickTable of Contents ( ). A clickable table of contents,
with titles and pages, is inserted at the cursor.
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Figure 4.15: Sample Table of Contents

How the table of contents is created:

• An entry is included for each text container in your document that uses one of the Heading styles, such as Heading
1. (For how to apply a paragraph style, see Applying and Changing Styles (page 25).)

• If your worksheet is organized with sections, those appear in the Table of Contents.

• Each entry is a hyperlink to a bookmark in the document. If you click one of the entries in the table of contents, you
go to that bookmarked location.

You can edit your document, including adding new headings or editing the current headings. You can also insert page
breaks, white space, etc. After editing, you'll want to update the table of contents.

To update the table of contents:

• Right-click on the table of contents, and select Update Table Of Contents from the context-sensitive menu.

4.8 Including Images and Drawings
You can insert images and drawings into your worksheet. On the Document tab of the ribbon, in the Insert group,
these are inserted by clicking Image ( ) or Drawing ( ).

When you insert a drawing, an empty grid appears. You can then use the drawing tools. You can also use the drawing
tools on an image or a plot.

You can resize an image or drawing using the grab box around the image.Tip: To maintain the aspect ratio on an image,
use the corner resizing handles. To maintain the aspect ratio on a drawing, hold the Shift key while resizing.

Drawing Tools

To view the drawing tools, select a drawing or an image in your Maple Flow worksheet. The associated Draw tab of
the ribbon is shown.

Drawing on Plots

To view the drawing tools on a plot:

• Select the plot in your Maple Flow worksheet. (Clicking once makes the math container with the plotting command
active. Click again to select the plot.) The Plot tab of the ribbon is shown by default.

• Click the Draw tab of the ribbon to switch to the drawing tools.

Available Tools

The Tools group consists of the following: selection tool, pencil (free style drawing), eraser, text insert, straight line,
rectangle, rounded rectangle, oval, diamond, and arc drawing tool.

Figure 4.16: Drawing Tools

Note: For the text, line, rectangle, round rectangle, oval, diamond, and arc tools,

- Click on the icon to activate it. The tool remains activated until you select another drawing tool.
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The rest of the drawing tools are alignment tools, drawing outline and fill tools, line style tool, the grid properties tools,
and the canvas and grid color tools.

Text

To insert text in the drawing canvas:

1. Click Text Tool ( ).

2. Click in the canvas (or on the image). A text box appears.

3. Enter text and modify font as necessary using the Edit tab of the ribbon to modify the font, font size, and so on.
Include math in the text box in the same way you include math in a text container. See Entering Math in a Text
Container (page 23).

4. Optional. Select a fill color for a text box or select the line color for the border in the same way it is done for objects.

Lines - Straight, Resizing, Adding Arrows

Drawing Straight Lines

To draw a straight line:

1. Click Line Tool ( ).

2. (Optional) From the Line Style menu ( ), select the line style, thickness, and arrow points:

3. In the canvas, click and drag the mouse. A straight line is drawn.

4. To complete the line, click the mouse twice or press Enter.
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5. You can draw more than one connected line; to complete your drawing, click the mouse twice, press Enter, or bring
the end of the last line back to the start of the first line.

6. To remove the last point drawn, press Esc.

Drawing a Line that Snaps to Vertical, Horizontal, or a 45 Degree Angle

To draw a line that snaps to an orientation that is a multiple of 45 degrees:

1. Click Line Tool.

2. In the canvas, click and drag the mouse.

3. Press and hold the Shift key to snap to a 45 degree increment.

4. To complete the line, click the mouse twice or press Enter.

Drawing a Line that is Attached to a Shape

To draw a line that is attached to a shape in the drawing canvas:

If you have inserted a shape in the canvas, you can draw a line that is automatically attached to that shape.

1. Click Line Tool.

2. Press and hold the Ctrl key, and, in the canvas, hover your mouse cursor over the existing shape to which you want
to attach the line. The shape is highlighted in green.

3. To draw the line, click and drag the mouse.

4. To complete the line, click the mouse twice or press Enter.

Resizing Lines

To resize objects drawn with straight lines:

1. Select the line to be resized using the selection tool.

2. With the mouse pointer over a grab box, click and drag the line to increase or decrease its size.

3. Release the mouse button.

To resize a shape and maintain the aspect ratio, hold the Shift key while resizing.

Changing Vertices of Lines

To change vertices of drawn lines in the canvas:

When an object is selected, grab boxes and nodes at the vertices are displayed.
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1. Click a node and drag the mouse to the desired point, thereby changing the vertex position.

2. Release the mouse.

Changing the Line Style

To change the style of drawn lines:

You can change the line style, thickness, and arrow points of a line either when it is drawn or afterwards.

1. Select a line using the selection tool.

2. From

3. the Line Style menu ( ) , select a line style, thickness, or arrow direction and shape.

The selected change is automatically applied to the straight line.

For example, here is a straight, thick line with a solid arrow on the right end. after clicking on the menu item displayed
above.

Rotating Images or Rotating Objects in a Drawing

You can rotate an image, or an object in a drawing. The process is the same.
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To rotate an object:

1. Select the object. The vertices of the object are designated by grab boxes.

2. Place the cursor at one of the vertices.

3. Press Ctrl. The rotate icon is displayed.

4. While pressing Ctrl, click the mouse and drag. The object rotates. Release the mouse once the object is positioned
as you want.

To return to the default rotation of an object:

1. Select the object.

2. Right-click and from the context menu, select Reset Rotation.

Color Selection Dialog

The drawing outline tool, drawing fill tool, and the canvas and grid color tools allow you to select colors for shapes,
lines, and the canvas grid lines. Choose a color by using one of the following tools in the color selection dialog:

Color Palette

To select a color, click a color from a palette of pre-defined colors.

The last five colors that you select are displayed in the box below the color swatches. If you want to view the RGB
values of a particular color, hover your mouse cursor over a color swatch.
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Color Wheel

To select a color:

1. Move the slider beside the color wheel to display a range of colors.

2. To select a color, click a point in the color wheel.

Color Value Sliders

To select a color, specify the RGB values of the color by moving the sliders. Alternatively, you can use the spinners
to scroll to certain values or type the values directly in the fields. For each RGB value, you can specify a number from
0 to 225.

Color Magnifying Glass

To select a color:

1. Select the eye dropper icon ( ).

2. Hover the color magnifying glass over an area on your screen that displays the color you want to select.

3. Using your mouse cursor, in the circle, click a point that displays the color.

To cancel your selection, right-click the circle.
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Pencil Tool for Free-Form Drawing

To draw with the pencil tool in the canvas:

1. From the drawing icons, click Pencil Tool ( ).

2. Click and drag your mouse in the canvas to draw lines. Release the mouse to complete the drawing.

Selecting Objects

To select items in the canvas use the Selection Tool ( ).

You can use the selection tool to select a single object or a group of objects. To select a group of objects:

Using the selection tool, click and drag the mouse around the items to be grouped. Release the mouse button. The items
are temporarily grouped.

Apply formatting as desired, for example by using the alignment tools in the Draw tab.

To temporarily switch to the selection tool (when using another tool), press and hold the Tab key. You can move and
resize objects. When you release the Tab key, the tool will revert to its previous setting. This allows you to tweak
something you just drew.

Filling Objects - Solid or Gradient Fill Colors

Filling an Object with a Solid Color

To fill an object with a solid color:

1. Select the object in the canvas.

2. Click Fill ( ), and select the solid fill style at the top (to the right of None).

3. From the same menu, click the left color bar at the bottom, and select a color from the color palette.
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4. To change the outline color (or line color), click Outline ( ) and select a color.

Filling an Object with a Gradient Color

To fill an object with a gradient color:

1. Select the object in the canvas.

2. From the menu, select one of the gradient fill styles, the square icons.

3. From the same menu, click the left and right color bars at the bottom to select a color from the color palette for each
part of the gradient.
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Filling an Object with an Image

To fill an object with an image:

1. Draw a rectangle or object in which an image is to be placed.

2. From the menu, click Browse and select an image.

The image is displayed in the rectangle or object on the canvas, plot, or image.
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5 Further Tools
5.1 Introduction
This chapter provides further details on a range of tools available in Maple Flow, including mathematical functions,
plots, using units in Maple flow, working with matrices, features that make authoring documents easier, and programming
via the code editor.

5.2 Functions
Maple Functions

Maple Flow is built on top of the Maple programming language. You can use most Maple functions in Maple Flow.

Maple package functions are used in the long form. For example, SignalProcessing:-FFT(). Note: Use of the with()
command to load packages is not supported.

The Maple programming language is described in the Maple online help: http://www.maplesoft.com/support/help.

Unsupported Maple Keywords, Commands, and Packages

As noted above, the with() command is not supported, and instead package commands should be called using the long
form of their name. In addition, some Maple keywords, commands, and packages are not supported. The following
are some examples, but not a complete list.

The assume command is not supported (use assuming instead). Some keywords, such as read and save, are not supported.

These Maple packages are not supported:

• Physics

• Tolerances

• DocumentTools (apart from the RunWorksheet command).

• Typesetting

• NaturalLanguage

Procedures can only be defined in the Code Editor. See Code Editor (page 61).

5.3 More Controls for Units
In Units (page 16), we describe how to add units to your computations. In this section we describe further tools for
controlling units in your computations.

Setting the Default Unit System

By default, units in output are displayed using the SI system of units. You can change the default system of units.

To set the default system of units:

1. From the File menu, click Options ( ).

2. Under the Units tab, select the desired output unit system, SI, FPS, or IPS.

3. Select Apply even if no operations are performed to force recalculation of the worksheet.

4. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.
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Figure 5.1: Setting the default unit system

This will not modify any units that have had units formatting applied directly as described Editing Existing
Units (page 17).

Changing the Units of a Result

Sometimes you want to control the units displayed in a result beyond setting the default system of units. There are two
ways of changing the units of a result: inline or through the Context Panel.

To change the units of a result inline:

1. Move the cursor into the output of the math container.

2. Delete the existing unit, and type the desired unit.

3. Press Enter or use the arrow keys to leave the math container. The result is updated.

For example, in this example, suppose we want the elapsedtime shown in minutes, not seconds.

Edit the right-hand side by deleting the unit s and typing min. When you press enter the result is calculated in the desired
units.

To change the units using the Context Panel:

1. Move the cursor into the output of the math container.

2. In the Context Panel for the result, select the desired unit from the Choose Unit list, and press Enter. You can also
type the desired unit in the Enter Unit field, for instance, if the Choose Unit list doesn't show the desired unit, as
the list is not exhaustive.
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Figure 5.2: Change units in Context Panel

Dimensional Balancing

If you change a unit of a result inline or via the Context Panel, and the unit is dimensionally inconsistent with the currently
displayed unit, Maple Flow automatically performs dimensional balancing by inserting additional units to make the
result dimensionally consistent.

Custom Units

You can define a custom unit, which will then be available for rescaling any result with units of equivalent dimension.
To define a unit:
1. Click a blank part of the

canvas to create a math
container, and then from the
Units palette insert the units
placeholder.

2. In the units placeholder, type
the name of your custom unit.

3. Use the right arrow key to
leave the units placeholder.

4. Type := (colon equals) to
create a definition.

5. Insert another units
placeholder from the Units
palette.

6. Enter the unit definition.

fpd can now be used to rescale any result with a dimension equivalent to length/time.
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5.4 Variables Manager
The Variables Manager in the palettes pane helps you keep track of the variables currently defined in your worksheet,
including any defined custom units.

As you move your cursor through the worksheet, the Variables manager dynamically updates to show what variables
are defined up to that point. Figure 5.3 shows an example of the variables manager for a worksheet.

Figure 5.3: The Variables Manager

FunctionButton
View - Inspect the value assigned to a
variable.
Hide - Hide a variable in the Variable
Manager
Filter - Filter the variables list so the
selected variables are shown.

This can be used to unhide a variable
you previously hid.

Inserting Variables into the Worksheet Using the Variables palette

Any variables that appear in the Variables palette can be inserted into the worksheet from the palette.

To insert a variable from the Variables palette into your worksheet, either:

• Right-click on a variable, then from the context menu, select Insert Into Worksheet.

or

• Double-click on the variable name in the Variables palette.

Notes:

Insert Into Worksheet is enabled only when:

• The grid cursor is on the canvas. In this case, a new math container is created into which the variable being inserted
is added.

• The cursor is currently in an active math container. In this case, the variable is inserted at the cursor location.
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5.5 Plots
You can create a plot with the Maple language plot command. A simple example is given in Figure 5.4.

Figure 5.4: A simple plot using a Maple plot command

Maple Flow also supports 3-D plots. A simple example is given in Figure 5.5.

Figure 5.5: A simple 3-D plot

You can rotate a 3-D plot.

To rotate a plot:

1. Double-click the plot. The Plot 3-D tab of the ribbon is shown. By default, the rotate tool ( ) is enabled. The
pointer changes to the rotate icon ( ).

2. Hold the left mouse button and drag the mouse to re-orient the plot.

3. Release the mouse button when the plot is oriented as desired.

The values of the angles theta, phi, and psi are displayed in the 3-D plotting toolbar to help you orient the plot. You
can also interact directly with the values of these angles.
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The orientation is determined by rotating the plot psi degrees around the x-axis, then phi about the (transformed) y-
axis, and then theta about the (transformed) z-axis.

To reset the view, click Reset view ( ). The rotation and zoom of the plot reset to the initial view.

You can resize the plot in the worksheet.

1. Select the plot, as shown in Figure 5.6.

2. Resize the plot. To maintain the aspect ratio, hold Shift while resizing.

Figure 5.6: Resizing a plot

Tip: When the plotting command is long, you may want to line break the command using Shift + Enter. This enters
a soft new line, and can be useful for controlling the width of math containers. It also makes it possible for you to resize
the plot narrower, since resizing is naturally limited by the width of the math container.

If you do not want to see the plot command at all, you can hide it as described in Hiding Commands (page 28).

5.6 Matrices
Entering and Using Matrices

Matrix Entry

There are a few ways to enter a Matrix.

The Matrix palette or Matrix command can be used to enter a matrix.

When you use the Matrix palette, shown in Figure 5.7, a template is inserted into the worksheet.

Figure 5.7: Matrix palette

47 • Further Tools



You can then replace the placeholders in the matrix template, using Tab to move between placeholders.

Figure 5.8: Matrix from palette

To add an additional row or column to a matrix, place your cursor in the matrix and right-click. From the context menu,
select one of:

• Insert Row Above

• Insert Row Below

• Insert Column to the Left

• Insert Column to the Right

Similarly, you can remove a row or column from the context menu.

Tip: Triple-click to select the entire matrix.

Indexing into Matrices

If you've made a matrix definition, such as , you can index into the matrix using indexed notation.

For example, to extract the first entry, you enter M[1,1]. This can by entered by hand or selected from the Expression
palette. To enter this from the Expression palette:

1. From the Expression palette, click . This template is inserted in the worksheet.

2. Replace the placeholders, using Tab to move between placeholders.

In Figure 5.7, further examples of matrix indexing are given.

Figure 5.9: Matrix indexing

Indexing into lists, vectors, or arrays works the same way.

Basic Matrix Operations
SyntaxOperation
M.N (period)Matrix multiplication

M-1 or LinearAlgebra:-MatrixInverse(M)Matrix inverse

48 • Further Tools



SyntaxOperation

M+ or LinearAlgebra:-Transpose(M)Transpose

elementwise(expression)Elementwise operations

The elementwise function allows you to apply operators and basic functions element-wise over data container(s) such
as matrices, arrays, or lists. For example, if M and N are matrices of the same dimensions, elementwise(3*log(M)*N)
applies this expression to the positional pairwise entries of these matrices.

More information can be found in the help system.

Viewing Large Matrices and Vectors

Matrices and smaller, and vectors with 10 or fewer elements, display in the document. For larger matrices
or vectors, a portion is shown inline.

For example, insert a matrix.

1. In the Matrix palette, specify the dimensions: 30 rows and 30 columns.

2. In the Type drop-down list, select a matrix type, for example, Random.

3. Click Insert Matrix. The command is inserted; evaluate and display the result.

Figure 5.10: Inline matrix browsing

Note the output shows ellipses indicating the data continues and the output is scrollable meaning that you can explore
the values directly within the worksheet, using your trackpad or mouse wheel. Click on the matrix, then use the scroll
bars or your trackpad or mouse wheel to scroll through the matrix data.

To view the entire matrix or vector, double-click the summary placeholder. This launches the Matrix Browser.

Back in the document, the context menu for the matrix has some controls.

• To remove the row and column headers, right-click on the matrix and clear the check boxes for Row Header and
Column Header.
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You can interactively resize the matrix, a single row, or a single column.

• To resize, click on the matrix, then resize from the bottom right corner of the matrix. Note the resize arrow seen
here:

• Similarly, change the size of a row or column interactively using the resize arrows.

• To fit the data better, you can also right-click on the matrix and select Fit Column to Data or Fit Row to Data.

• To return to the initial matrix view, right-click on the matrix and select Reset Output Display.

• To disable the scrollable functionality, right-click and Freeze Scrollable Output from the context menu. This also
freezes the Matrix in its current size and position.

Set Displayed Matrix Size

In Figure 5.10, for the matrix, a certain number of rows and columns are displayed. By default, 10 rows and 10 columns
are displayed in output for any matrix. The same rules apply to one-dimensional and multidimensional data stored as
arrays.

In addition to interactive controls you can change this displayed matrix size in the Options dialog. This allows you to
set the visible matrix size for all matrices.
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To set the maximum number of rows and columns displayed:

1. From the File menu, click Options ( ).

2. Under the Display tab, specify the desired values under Output matrix size for:

• Row limit

• Column limit

3. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.

Figure 5.11: Set matrix size

Set Matrix Save Limit

If a worksheet that contains a large matrix is saved and reopened, the data is saved and is scrollable as long as the
matrix has 5000 or fewer entries. With larger matrices, you will need to re-execute or re-import the matrix before
scrolling. This limit can be changed in the Options Dialog:

1. From the File menu, click Options ( ).

2. Select the General tab.

3. Enter your value for RTable output save limit.

4. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.

Data Import Assistant

The data import assistant makes it easy to import your data into a worksheet. Supported file types include CSV, delimited,
and Excel files, as well as audio files, image files, and graph formats.

To import data:

1. Click on a blank part of the canvas to create a math container.

2. On the Math tab of the ribbon, click Import Data ( ). The Data Import Assistant opens.
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3. Browse to select a file to import.

4. Follow the steps in the assistant. When prompted, specify a variable name to which to assign the imported data.

5. Click done when prompted. A command is inserted into the math container that will import the data.

Figure 5.12: Import data

5.7 Using a Drop-Down List
Drop-down lists in Maple Flow make it easy to create a worksheet with interactive elements.

The items in the drop-down list can be entered directly in the list editor (a static item list), or the list can be populated
from a list, matrix, or other data structure that has been defined in your worksheet. The selected item in the list can be
used in the worksheet for further calculations or analysis.

To add a drop-down list to your worksheet:

1. Click a location in your worksheet where the drop-down list will be inserted. A typical use of the drop-down list is
on the right-hand side of a definition, as demonstrated in the examples.

2. From the Components palette, click the drop-down list icon ( ). A drop-down list is inserted in the worksheet.

3. Specify properties for the drop-down list in the context panel.
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Figure 5.13: Drop-down list properties

• Name: (optional) Provide a name for the drop-down list.

• Tooltip: (optional) Provide a tooltip, which is shown when you hover over the component.

• Item list data: Select from Static item list or from the list of available data sets in your worksheet. See Example 2.

• Edit Static Item List: Click to open the List Editor.

• Entries as strings: Select this check box if the entries should be parsed as strings.

• Return: Select Index, Selection, or Data.

• List items in: Select First column or First row.

• Use fixed width: Select this check box to make the drop-down list a fixed width.

• Width: (For a fixed-width box) Specify width in pixels. The default is 300.

Example 1

In this example the drop-down list is populated interactively, through the list editor.

1. Click on the canvas to create a new math container, and type Day:=

2. From the Components palette, click the drop-down list icon. The drop down list is inserted.

3. In the Context Panel, click Edit Static Item List.

4. Replace the placeholder entry (DropDownList) with Monday. Add new items for Tuesday, etc.

5. Click OK when finished.

6. In the Context Panel, for Tooltip, type select one.

7. In the Context Panel, for Return, select Selection.

8. In a new math container, type Day=
The value of this is the selected item from the list. Change the selected item in the list, and the result of this reflects
the current selection.

53 • Further Tools



Using the List Editor

Edit the list editor using the buttons Insert Above, Insert Below, andRemove, as well as the keyboard shortcuts listed
in the following table, and the tip described below it.

MacWindowsAction
EnterEnterActivate the row and select all contents
DeleteBackspaceActivate the row with the contents removed
Left arrowLeft arrowActivate the row with the cursor at the start

of the content
Right arrowRight arrowActivate the row with the cursor at the end

of the content
Command + KCtrl + KInsert row above the current selection
Command + JCtrl + JInsert row below the current selection
Command + DeleteDeleteDelete the current selection
Command + Up arrowCtrl + Up arrowMove the selection up one row
Command + Down arrowCtrl + Down arrowMove the selection down one row

In addition, if you select one or more rows you can drag them to a new location.

Example 2

In this example, we first define a two-dimensional matrix, and then we use that matrix to fill the items in our drop-
down list. When you select an item from the list, the return is the corresponding value in the second column.

1. In a math container, type density :=

2. Insert a 3x2 matrix from the Matrix palette. Tab through the placeholders, replacing them as shown here.
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3. In a new math container, insert a drop-down list from the Components palette.

4. In the Context Panel, for Item list data, note the list is populated with the matrix you already defined. Select density.

5. In the Context Panel, for Return, select Data.

6. Back in the worksheet, click on the drop-down list and use the arrow keys to move to after the component, and type
=. You can see the return value comes from the second column. Use arrow keys to navigate to before the drop-down
list and assign it to a name. Now you can use this value in calculations.

The Design of a Strut Mechanism application (found in the Application Gallery under Mechanical Engineering)
provides another example of the drop-down list in use.

5.8 Ease of Use Features
Maple Flow includes additional ease of use features:

• Maple Flow includes an interface to powerful AI technology through the AI Formula Assistant.

• Command and argument completion offer an easy way to get your syntax right when working with commands in
Maple Flow.
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AI in Maple Flow

The AI Formula Assistant is an innovative tool designed to help you find formulas and equations you need.

The AI Formula Assistant is found on the left side of the Maple Flow window. Click the AI Formula Assistant tab to
activate that panel.

Figure 5.14: AI Formula Assistant tab

Before using this feature, you'll need to agree to the terms of use.

• Click the AI Terms of Use button.

• Read and accept the terms and click Apply Globally.

• You can return to the terms of use at any time by clicking the Gear icon ( ) at the bottom of the AI Formula
Assistant pane. Alternatively, in the Options Dialog, in the General tab, click AI: Terms of Use.

To search for an equation or formula:

1. (Prerequisite) Agree to the terms of use.

2. Enter a phrase, question, or series of words separated by commas and then click Search. For example,

For example, you could search for

• friction factor in turbulent flow

• non-ideal diode equation

• What is the formula for the volume of a cone?

You can continue to use Maple Flow while your result is being processed, if needed, so you remain productive while
the service is finding your answer.

When the response appears, the name of the formula is displayed, and then in the text box is information that includes
the equation, any context, and a description of the variables that appear in the equation.
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Figure 5.15: AI Formula Assistant example

3. Use the Formulas drop-down list to select from the related formulas returned from the AI search.

4. If desired, you can insert a formula into a Maple Flow worksheet by first placing your cursor at the desired insertion
position, and then clicking Insert formula.

Notes:

- This feature relies on sending your query to a third party AI tool, and, as a result, the answers you get may
not be accurate or complete. Maplesoft cannot control the quality of the response.

- Maple Flow interfaces with OpenAI's models. At the time this document was published, Open API's o3-mini
model was used. Note that OpenAI may deprecate and disable models, so the models supported may change
in the future.

- An equation inserted from the AI Formula Assistant may need to be edited to be in proper Maple Flow math
notation.

- At times, you may encounter an error message when you try to insert an equation. In such a case, you may
still be able to manually copy and paste from the AI Search Assistant into the worksheet.

- You can disable the connection to AI Technology, as described in the following section.
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Disable AI Connection

By default, the AI Formula Assistant pane is visible and the connection is enabled after you accept the Terms of Use.
If you do not accept the terms of use, the connection is not enabled. If preferred, you can configure Maple Flow to
disable the connection to AI so that the AI Formula Assistant pane does not appear in the Maple interface.

To disable the AI connection, modify the user preferences file:

1. Close Maple Flow.

2. Open the user preferences file for Maple Flow in a text editor. It is usually found here:

• Windows:

C:\Users\<User ID>\AppData\Roaming\Maple\<version>\MapleFlow.ini.

• macOS:

//Users/$USER/Library/Preferences/Maple/<version>/Maple Flow preferences.plist

3. Find the entry TurnOffAI and edit it to

TurnOffAI=true

4. Save and close the preferences file.

After you have disabled the AI connection, when you open Maple Flow, the AI Formula Assistant does not appear,
the link to the AI Terms of Use in the Options Dialog is hidden from the Maple Flow interface, and you cannot query
the AI through Maple Flow.

Command Completion

Maple Flow offers a dialog for command completion. When typing in a math container, Maple Flow suggests commands
and templates that match what you have already entered.

The command completion dialog is initiated by pressing Esc or Ctrl + Space.

Figure 5.16: Command completion window

The command completion lists include command names and templates. If there are any placeholders in your selection,
they appear in a colored font. Replace the placeholders in the template, using Tab to move to the next placeholder.

Automatic Command Completion

In addition, when typing in a math container, Maple Flow offers automatic completions for items that are unambiguous.
When such a suggestion is available, it appears as a yellow annotation. Pressing theEsc orTab key inserts the suggested
item.
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Argument Completion

Similar in concept and design to command completion, aurgument completion makes it easier to enter commands.
When enabled, as you type commands, Maple Flow offers automatic completions for arguments in many useful cases
by displaying a popup list of suggested completions.

To use argument completion:

1. If only one item is suggested, press Tab to insert the suggested item into your expression.

2. If more than one item is listed, use the arrow keys to select an entry then press Tab. You can alternatively use your
pointer to select an entry from the list.

The argument completion list can include examples for some suggested items. In such a case, if you select that entry,
the example is inserted.

The argument completion list will also include your previously defined variables, if they are of an appropriate type for
the argument.

Example: Finding the solution to a matrix equation of the form Ax=B using LinearAlgebra:-LinearSolve.
1. Define a matrix P and a vector z.

2. Type LinearAlgebra:-LinearSolve(
A popup list appears. The second suggestion is the
matrix you've defined above, P. Select this item.
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3. Type a comma.
Another popup list appears. Find and select the entry
for z. In this case, it is the last entry listed.

4. Close the parenthesis for the command's arguments,
and type =
The problem is complete.

Note: Automatic argument completion is off by default.

To turn on argument completion:

1. From the File menu, click Options ( ).

2. Select the Interface tab.

3. Select the Automatic argument completion check box.

4. Click either Apply to Session or Apply Globally.
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5.9 Code Editor
The Code Editor lets you write Maple procedures to use in a Maple Flow canvas. To learn how to write a Maple pro-
cedure, read the online Maple Programming Guide:
https://www.maplesoft.com/support/help/Maple/view.aspx?path=ProgrammingGuide/Contents

To view the code editor, on the Math tab of the ribbon, click Code Window ( ).

Note: You can only enter proc definitions in the code editor. That is, your code should be in the form:
FirstProc:=proc(...) ... end proc;
NextProc:=proc(...) ... end proc;

To define the procedure, enclose a sequence of statements between proc(...) and end proc statements, and specify the
parameter name(s) in the parentheses after the proc statement. For example, a simple definition for a procedure that
takes one parameter and returns the square of the parameter is:

MyProc:=proc(x) x^2; end proc;

5.10 Restore Backup
You can restore a backed up document.

By default, backups of open files are automatically saved. See more information below.

To restore backups:

1. From the File menu, select Restore Backup ( ). All backed up files are listed.

2. In the Open Backup Files window, select the backup file that you want to open.

3. Click Open. Use Save As to save the backup file as a Maple Flow worksheet.

Auto Save

By default, the auto save feature automatically saves all open documents.

To change this setting:

1. From the File menu, click Options ( ).

2. Under the General tab, select or clear the Auto save check box.

3. Change the frequency for saving files by entering the number of minutes.

4. Select the Keep files check box (described below).

5. Click Apply to Session, Apply Globally, or Cancel.
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Auto save saves a copy of the file. The filename is the worksheet's filename with _MAS appended to it. When the
worksheet is manually saved, the _MAS file is deleted.

When you open a _MAS worksheet that has been automatically saved, the worksheet is read-only. Therefore, you must
use Save As to save the _MAS worksheet as a Maple Flow worksheet.

Auto save does not save the worksheet if the worksheet has not been changed.

The auto save files are saved in a subdirectory of your home directory. For example,

• On Windows, C:\Users\userid\mapleflow\backup, where userid is your user ID.

• On Mac, $HOME/MapleFlow/Backup

Keep Files: You can control whether auto save files are kept or deleted when Maple Flow is shut down normally.

• To retain the auto save files when Maple is shut down normally, in the Auto save settings, select Keep files. With
Keep files selected, Maple creates multiple copies of backup files.

• To discard the auto save files when Maple is shut down normally, clear the Keep files check box.

5.11 Logging Debugging Information
Maple Flow uses a log file. It always includes some information on the startup routine.

If necessary, you can enable the logging of debugging information into the log file. This information may be needed
if you contact Technical Support.

To enable logging of debugging information:

1. From the File menu, click Options ( ).

2. Under the General tab, select Include debugging information in log file.

3. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session and future sessions.
Now, the log file will include information that can be used for troubleshooting.

Note: The log file is located here:

• On macOS: ~\Users\username\.maplesoft\maplesoft.log
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• On Windows: C:\Users\username\.maplesoft\maplesoft.log
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6 Printing and Exporting to PDF
6.1 Printing a Maple Flow Document
The following sections describe settings you can control when printing or exporting to PDF.

Whenever you prepare a document for printing or export to PDF, the entire document re-evaluates if needed so everything
reflects the current state.

6.2 Print Extents
You can display print extents. When this mode is selected, dashed horizontal and vertical lines indicate the extents of
a printable page, taking into account the chosen page size, margins and headers/footers. Pages are printing column-by-
column.

To enable Print Extents:

• On the Document tab of the ribbon, in the View group, select Print Extents.
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Figure 6.1: Print extents

The on-screen positioning and size of math, text, plots, and images will be reflected in the printed page or exported
PDF.

Note: If you only want to print the left-most page, under File > Print > Print Settings, select Print single page width.
This is useful, for example, if you write extra notes to the side of your work. By using print extents and this setting,
you can ensure those notes do not end up in the printed version of your document.
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6.3 Headers/Footers
You can specify a header and/or footer. This will be seen in the printed page or exported PDF, but not in the working
environment.

To enable Print Extents:

• On the Document tab of the ribbon, select Header and Footer ( ).

Figure 6.2: Inserting Headers and Footers

Headers and footers can be customized, making it easy to create standardized templates. A header or footer can include
date, timestamp, image, document name, page number, and so on. You can draw borders around the header, footer, or
the body of the document.

To create a multi-line header or footer, use a newline character.

• On Windows, use \n

• On Mac, use \r

For example, to create a multi-line header in Windows that contains the date and timestamp on different lines:

1. On the Document tab of the ribbon, select Header and Footer ( ).

2. In the Header and Footer window, select the Custom Header tab.
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3. In the Left: text field, click .

4. Also, in the Left: text field, after the newly inserted date, type "\n".

5. Click . The Left: text field will look like this:

6. Click OK.

7. Finally, If you open Print Preview, your header should look like this:

Note: For headers or footers on the same line, use the spacebar to insert a space between header or footer elements.

Apply a Header or Footer to All Your Documents

To apply the header or footer to all documents:

• Select Apply Globally.

To remove the global definition, open the header/footer dialog and select None for both header and footer, and check
Apply Globally.

To edit the global definition, open the header/footer dialog, made the desired edits, and then check Apply Globally.

Additional Options

To access additional formatting options, click Options.
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From the Options menu, you can adjust:

Start headers on page. Use the option arrow buttons to select on which page you want the headers to begin appearing.

Start page numbers at. Use the option arrow buttons to select the page you want numbering to begin appearing.

Date Format: You can adjust the date format in your header or footer by selecting one of the available options from
the list.

Displayed asDate Format Choice
Short

Medium

Long

Full

Scale Image. Scale the size of the inserted image as a percentage of the original size.

6.4 Page Setup
The Page Setup dialog lets you change the page size, orientation, and margins, for printing.

Figure 6.3: Page Setup

To specify the page setup for one document:

• Use File > Print > Page Setup ( ) to specify the settings.

The page layout is saved with the document and remembered when it is reopened.
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To set the default page layout:

1. From the File menu, click Options ( )

2. In the Template tab, click Set default page layout. The Page Setup dialog opens. Specify the settings and click
OK.

3. Click Apply to Session to apply for the current Maple Flow session only, or click Apply Globally to apply the
setting to the current session an future sessions.

6.5 Print Preview
The File > Print > Print Preview menu lets you preview the printed page or exported PDF.

6.6 Export to PDF
On Windows:

To export the worksheet to PDF:

1. Select File > Export As ( ).

2. Browse to the desired location and specify a filename. Click Save.

On Mac:

To create a PDF of the worksheet:

1. Select File > Print.

2. Select Save as PDF.

3. Specify a filename. Click Save.

6.7 Printing a Worksheet with Sections
Whether printing or exporting to PDF, if your Maple Flow worksheet has sections, you can select how it is printed.

Select File > Print > Print Settings. Select one of the following:

• Print/export document with all sections expanded.

• Print/export document keeping sections exactly as shown on-screen.

If you selected the first option, in addition, specify whether to print the section boundary markers.

For more information on controlling the display of sections, see Controlling the Display of Sections (page 27).
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7 Maple Flow Add-in for Excel
7.1 Introduction
The Maple Flow Add-in for Microsoft® Excel lets you run Maple Flow worksheets from an Excel spreadsheet.

You can use the Maple Flow Add-in for Excel to:

• Provide a simple spreadsheet-based interface for your Maple Flow worksheets, presenting only the inputs you want
users to change, and outputs you want users to view.

• Use Excel to perform parameter sweeps on a Maple Flow worksheet.

• Use the optimization tools available in Excel to find the parameter values that drive a Maple Flow worksheet to a
minimum, maximum, or a given value.

Within Excel, Maple Flow worksheets can be treated as a "black box." You can

• send parameter values from Excel into the Maple Flow worksheet,

• and extract the value of selected variables into Excel.

In addition to a function you can call from an Excel cell, a convenient interface lets you

• Browse to pick a Maple Flow worksheet.

• View all the parameters defined in the worksheet, together with their initial values.

• Choose which parameters you want to vary from Excel.

• Choose which results you want to return to Excel.

7.2 Requirements
Using the Maple Flow Add-in for Excel requires:

• Excel 2019 or Excel 365

• Maple Flow 2025.1 or higher

• Windows operating system
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7.3 Enabling the Add-in for Excel
To enable the Maple Flow Add-in for Excel:

• In Excel, go to File > Options > Add-ins.

• In the Manage box, select Excel Add-ins, and then click Go.

• Click Browse and navigate to the Excel subdirectory of your Maple Flow installation, for instance, C:\Program
Files\Maple Flow 2025\Excel.

• Select the file WMIMPLEX64.xla and click OK.

Figure 7.1: The Maple Flow Add-in for Excel toolbar

The first four buttons on the left should be ignored if you do not have Maple installed. They cannot be used with
Maple Flow.

The button on the right, as see in Figure 7.2, initiates the Maple Flow Worksheet Wizard.

Figure 7.2: Maple Flow Worksheet Wizard button

7.4 The MapleFlow Command
After it is installed, the Maple Flow add-in for Excel provides you with a command that lets you interrogate a Maple
Flow worksheet from an Excel cell. The command is called MapleFlow and defines

• what variables are inputs, and the cells in which they are found in Excel

• what variables are outputs, and the cells in which they should be exported to in Excel

The two calling sequences are described below.

Calling Sequence 1

Syntax
=MapleFlow(filePath,{input_labels},{input_values},{output_labels},substitutions,horizontal_or_vertical)

DescriptionFormatParameter
Path to the Maple Flow worksheetStringfile_path
Name of variables in the worksheet whose
value is to be changed

Strings of the form
"in_name_1","in_name_2","in_name_3",…

input_labels

Values of variables to be changed, in the
same order as input_labels

Strings of the form "in_value_1", "in_value_2",
"in_value_3",…

input_values

Names of variables whose value is to be
extracted into Excel

Strings of the form "out_name_1",
"out_name_2","out_name_3"

output_names
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DescriptionFormatParameter
Values to be substituted into input_values
to replace references to &1, &2, &3 etc

Optional cell references of the form
cell_1,cell_2,cell_3,…

substitutions

Determines if matrix results are to be
spilled into rows ("horizontal") or columns
("vertical")

Optional string of the form "horizontal" or
vertical" (default: horizontal)

horizontal_or_vertical

Example

Consider a Maple Flow worksheet (called Excel.flow and located in C:\temp) that defines values a, b, and c, and cal-
culates d and e.

Consider an Excel spreadsheet that is structured like so:

where

• the inputs a, b, and c are in columns A, B and C.

• columns D and E will contain the outputs d and e.

This formula is entered into cell D2
=MapleFlow("c:\temp\excel.flow",{"a","b","c"},{"&1","&2","&3*Unit(W)"},{"d","e"},A2,B2,C2)

Cells D2 and E2 are now populated with the values of c and d calculated from the worksheet.
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Note: The MapleFlow command returns a matrix which "spills over" into cell E2.

Calling Sequence 2

This is the calling sequence returned by the Worksheet Wizard. For more information, see Maple Flow Worksheet
Wizard Tutorial (page 75).

Syntax
MapleFlow(filePath,input_label_cell,input_value_cell,output_label_cell,horizontal_or_vertical)

DescriptionFormatParameter
Path to the Maple Flow worksheetStringfile_path
Name of variables in the worksheet whose
value is to be changed

Cell reference or cell rangeinput_label_cell

Value of variables to be changed in the
worksheet

Cell reference or cell rangeinput_value_cell

Names of variables whose value is to be
extracted into Excel

Cell reference or cell rangeoutput_label_cell

Determines if matrix results are to be
spilled into rows ("horizontal")

Optional string of the form "horizontal" or
vertical" (default: "horizontal")

horizontal_or_vertical

Example

Consider a Maple Flow worksheet (called Excel.flow and located in C:\temp) that defines values a, b, and c, and cal-
culates d and e.
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The initial Excel spreadsheet is structured like so:

Note that:

• The input variable names are in range A1:C1.

• The input variable values are in range A2:C2.

• The output variable names are in range D1:E1.

If the user enters the following formula into cell A...
=MapleFlow("C:\temp\Excel.flow",A1:C1,A2:C2,D1:E1)

...then the following result is seen in Excel.
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7.5 Maple Flow Worksheet Wizard Tutorial
Here, we will demonstrate the use of the Worksheet Wizard with the use of an existing worksheet installed with Maple
Flow.

1. Start Excel and click once on a cell in Excel. (Do not double-click to force focus inside a cell.)

Figure 7.3: Selecting where you want your Maple Flow inputs and outputs in Excel

In the add-in toolbar, click the Maple Flow Worksheet Wizard button (Figure 7.2). This initiates the Worksheet Wizard
menu (Figure 7.4).
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Figure 7.4: Initial Worksheet Wizard screen

2. Click Browse and navigate to the data\examples subdirectory of your Maple Flow installation, for instance,
C:\Program Files\Maple Flow 2025\data\examples.

Figure 7.5: File browser for Maple Flow Worksheet Wizard

3. Select CompressorPowerforaSupersonicWindTunnelatSteadystateandStartup.flow and then click Open.

4. Click Load Variables.
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The Worksheet Wizard now shows all the variables and functions defined in the worksheet, together with their initial
values. See Figure 7.6.

a. Any check boxes selected in the IN: column are the variables you want to vary from inside Excel.

b. Any check boxes selected in the OUT: column are the variables you want to export to Excel.

Figure 7.6: Worksheet Wizard populated by variables and initial values

5. In the IN: column, select D__test, M__test, and height.

6. In the OUT: column, select P__start and P__steady.

Figure 7.7 illustrates what you should now see.
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Figure 7.7: Picking inputs and outputs in the Worksheet Wizard

7. Clicking Insert inserts the communication command inside the Excel cell. See Figure 7.8.

Figure 7.8: Content inserted into Excel by the Worksheet Wizard

If you change the values of D__test, M__test, and height, you will see updated results for P__start and P__steady.
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Figure 7.9: Spreadsheet content after parameters are changed

Clicking the cell next to P__start reveals the formula inserted by the Worksheet Wizard. See Figure 7.10.

Figure 7.10: Function inserted by the Worksheet Wizard
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8 Keyboard Shortcuts
Maple Flow provides many keyboard shortcuts for ease of use. These are given in the following tables.

Table 8.1: Keyboard shortcuts for canvas operations

MacWindows
Canvas operations

ReturnEnterWith the grid cursor on an empty row: move the grid
cursor, and all content below the grid cursor, down

BackspaceBackspaceWith the grid cursor on an empty row: move the grid
cursor, and all content below the grid cursor, up

DeleteDeleteWith the grid cursor on an empty row: move all
content below the grid cursor up

Command + arrow keysCtrl + arrow keysWith the grid cursor on a container: move the
container

Command + Shift + arrow keysCtrl + Shift + arrow keys
Command + DeleteCtrl + DeleteWith the cursor in a container: delete the container
TabTabMove to next container
Shift + TabShift + TabMove to previous container
Command + HomeCtrl + HomeCursor to top of canvas (first container)
Command + EndCtrl + EndCursor to bottom of canvas (last container)

Table 8.2: Keyboard shortcuts for math entry

MacWindows
Math

==Evaluate math and display output*
Command + ReturnCtrl + EnterUpdate math container, then continue editing
Command + =Ctrl+ =Entering an equal sign to mean equality*
Command + Shift + UCtrl + Shift + UAdd units to a value or expression
[←][→][↑][↓][←][→][↑][↓]Navigate through expression
[→][→]Move cursor to different level in expression, e.g. out

of exponent
x/yx/y

Fraction

x\/yx\/yInline fraction
x__nx__n (two underscores)Literal subscript

x^nx^nExponent
Esc, orEsc, orCommand or symbol completion

Command + Shift + SpaceCtrl + Space
Command + GCtrl + GEnter a Greek character**
Tab, orTab, orNavigate between placeholders in a math expression

Shift + Tab (navigate backwards)Shift + Tab (navigate backwards)
Ctrl + SAlt + SToggle between numeric/symbolic mode for math

container
Shift + ReturnShift + EnterSoft new line
Command + ECtrl + EDisable/enable evaluation of the worksheet
F6 + Command + . (period)F6Interrupt evaluation
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* You can change the behavior of the = key in a math container through the Options > Evaluation dialog. For details,
see Controlling Evaluation (page 20).

Some notes on the evaluation shortcuts on international keyboards are found in the following table.

Table 8.3: International keyboard shortcuts for evaluation

Japanese keyboardGerman keyboard
Shift + -, for Mac and WindowsShift + 0, for Mac and WindowsEvaluate math and display output

Ctrl + Shift + -, for WindowsShift + Alt + 0, for WindowsEntering an equal sign to mean equality

Command + Shift + -, for MacCommand + Shift + 0, for Mac

** To enter a Greek character, type the indicated Roman letter from the keymap in the following table, then type Ctrl
+ G (Command + G, for Mac) to get the corresponding Greek character.

Table 8.4: Greek keymap

Uppercase
Greek

TypeLowercase
Greek

Type

Aa

Bb

Cc

Dd

Ee

Ff

Gg

Hh

Ii

Jj

Kk

Ll

Mm

Nn

Oo

Pp

Qq

Rr

Ss

Tt

Uu

Vv
Ww
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Uppercase
Greek

TypeLowercase
Greek

Type

Xx

Yy

Zz

Table 8.5: Keyboard shortcuts for text entry

MacWindows
Text

SpaceSpaceCreate a text box
Command + RCtrl + RSwitch to math entry in a text box
Command + TCtrl + TSwitch back to text entry

Table 8.6: Keyboard shortcuts for drop-down list editor

MacWindowsAction
EnterEnterActivate the row and select all contents
DeleteBackspaceActivate the row with the contents removed
Left arrowLeft arrowActivate the row with the cursor at the start

of the content
Right arrowRight arrowActivate the row with the cursor at the end

of the content
Command + KCtrl + KInsert row above the current selection
Command + JCtrl + JInsert row below the current selection
Command + DeleteDeleteDelete the current selection
Command + Up arrowCtrl + Up arrowMove the selection up one row
Command + Down arrowCtrl + Down arrowMove the selection down one row

Table 8.7: Drawing tools shortcuts

MacWindows
CommandTabSwitch temporarily to the selection tool (when using

another tool)
OptionCtrlRotate object

Table 8.8: Keyboard shortcuts for menu operations

MacWindows
AltAltAccelerator key for ribbon

File
Command + NCtrl + NNew
Command + OCtrl + OOpen
Command + WCtrl + F4Close worksheet
Command + SCtrl + SSave
Command + Shift + SCtrl + Shift + SSave as ...
Command + PCtrl + PPrint
Command + Shift + PCtrl + Shift + PPage setup
Command + QAlt + F4Exit

Home
Command + ZCtrl + ZUndo
Command + Shift + ZCtrl + YRedo
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MacWindows
Command + FCtrl + FFind/Replace
Command + 0Ctrl + 0Zoom factor—default
Command + 1Ctrl + 1Zoom factor 75%
Command + 2Ctrl + 2Zoom factor 100%
Command + 3Ctrl + 3Zoom factor 125%
Command + 4Ctrl + 4Zoom factor 150%
Command + 5Ctrl + 5Zoom factor 200%
Command + 6Ctrl + 6Zoom factor 300%
Command + 7Ctrl + 7Zoom factor 400%
Control + Shift + =Alt + Plus, orZoom in

Alt + =
Control + Minus, orAlt + -Zoom out

Control + Shift + Minus
Command + Shift + CommaCtrl + CommaRemove section
Command + ACtrl + ASelect all
Command + BCtrl + BBold
Command + ICtrl + IItalic
Command + UCtrl + UUnderline

Math
Command + Shift + ECtrl + Shift + ECode window

Document
Command + ReturnCtrl + EnterPage break
F7F7Spellcheck

Help
F1F1Maple Flow Help
F2F2Help on Context

Table 8.9: Mouse bindings

MacWindows
Single-clickSingle-clickLocate cursor
Double-clickDouble-clickSelect current word, in text container
Triple-clickTriple-clickSelect entire matrix, piecewise expression, or

container
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Index
Symbols
:=, 12

align results under definition operator, 27
=

for equality, 12
to display results, 11

international keyboard shortcuts, 81

A
accuracy, 19
AI

disable connection, 58
terms of use, 56

AI formula assistant, 56
align

containers to the left, 9
result on new line, 27

argument completion, 59
assigning

align results under :=, 27
hide commands and name, 28
value to a name, 12

auto save, 61

B
background color

for container, 23
backup files, 61
bookmarks, 29
bring

to front/back, 10

C
canvas, 4
code editor, 61
command completion, 58
commands

getting help on, 3
complex numbers, 17
components palette

drop-down list, 52
shortcut, 31

context panel, 4, 14
control display of math

hide commands, 28
numeric formatting of result, 14
symbolic or numeric result, 13

control display of results
align under :=, 27

control editability of document, 29

D
debugging

log file, 62
defining procedures, 61
definition

creating, 12
Digits

for numerical evaluation, 19
drawings

creating, 33
drop-down lists, 52

E
editable option, 29
editing, 8
editing units, 17
elementwise, 48
entering

math container, 8, 11
text container, 8, 23

entering math
basics, 15
command completion, 15
complex numbers, 17
definition, 12
in a text paragraph, 23
nonexecuting, 20, 21, 23
phasors, 17
using =, 12

option to change evaluation keys, 20
using palettes, 15

entering units, 16
error message

expecting operator, 15
evalf, 13
evaluation

disable temporarily, 21
interrupt, 20
only visible containers, 20
order of, 20
progress bar, 20
using =, 11

international keyboard shortcuts, 81
evaluation modes

numeric and symbolic, 13
Excel add-in, 70

requirements, 70
setup instructions, 71
tutorial, 75

expecting operator, 15
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F
flip

to front/back, 10
format

section style, 27
using character formatting, 25
using style sets, 25

functions
Maple, 42

G
graphing, 46
Greek characters

entering, 81
grid, 8

H
help

on additional Maple commands, 3
help system, 3
hide commands, 28
hyperlinks

inserting, 29

I
i, 17
images

drawing on, 33
inserting, 33

import data
using assistant, 51

indexing
into matrices or lists, 48

insert
header or footer, 66
section, 26

K
keyboard shortcuts, 80

L
linking

to a bookmark, 29
to another worksheet, 29

location
grid cursor, 8

M
Maple Flow

versus Maple, 2
Maple Flow add-in for Excel, 70

Maple Flow window, 4
math container

for display only, 20
set background color, 23

matrix
entering, 47
importing data for, 51
large, 49
operations, 48
random, 49
select entries, 48
set matrix save limit, 51
set visible matrix size, 50
view entries, 49

moving
math container, 8

changes evaluation order, 20
text container, 8

N
numeric evaluation, 13
numeric formatting options, 14

O
open

in new window, 7
Options

default zoom, 5
display

set number format, 14
evaluate

entire worksheet, 20
evaluation keys, 20
on loading worksheet, 20
on saving worksheet, 20
only visible containers, 20

P
packages

using Maple, 42
palettes, 4, 15, 47

units, 16
variables, 45

pasting
in math container, 11

PDF
export to, 69

phasors, 17
pi, 13
plotting, 46
print

set default page layout, 68
settings for sections, 69
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single page width only, 64
print preview, 69
printing, 64
programming, 61

R
random

matrices, 49
ribbon, 4

alt keys, 5
collapsing, 5

rounding
specify decimal places, 14

rtablesize option, 51

S
scientific formatting, 14
section

expand or collapse, 26
sections, 26

display of, 27
shortcuts

inserting, 29
start page, 1

customize, 6
status bar, 20
symbolic evaluation, 13
syntax

documentation, 42
for commands, 58

T
table of contents, 32
tabs

reordering, 7
text

formatting, 23
formatting using built-in styles, 25
using character formatting, 25

text container, 23
entering math in, 23
set background color, 23

troubleshooting
logging debugging information, 62

turning evaluation off, 21
tutorials, 1

U
units, 16, 42

add custom unit, 44
changing units of a result, 43
default units system, 42

dimensional balancing, 44
rescaling, 17

V
variables

manager, 45
vector

large, 49
view

print extents, 64
visual indicators, 12, 21, 28, 31

Z
zoom

set default, 5
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